const regex = /^.*?(\bEventname 2\b).*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(\\bEventname 2\\b).*$', 'g')
const str = `<select id="filter_event_id" name="filter_event_id" class="inputbox chzn-done" onchange="submit();" style="display: none;">
<option value="0">Select Event</option>
<option value="113">Eventname (RB113) (02-05-2015)</option>
<option value="104">Eventname 2 (T104) (09-05-2015)</option>
<option value="109">Eventname 3 (M109) (15-05-2015)</option>
<option value="99" selected="selected">Eventname 4 (M99) (24-04-2015)</option>
</select>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}