import Foundation
let pattern = #"^.*?(\bEventname 2\b).*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<select id="filter_event_id" name="filter_event_id" class="inputbox chzn-done" onchange="submit();" style="display: none;">
<option value="0">Select Event</option>
<option value="113">Eventname (RB113) (02-05-2015)</option>
<option value="104">Eventname 2 (T104) (09-05-2015)</option>
<option value="109">Eventname 3 (M109) (15-05-2015)</option>
<option value="99" selected="selected">Eventname 4 (M99) (24-04-2015)</option>
</select>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)