import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(\\bEventname 2\\b).*$";
final String string = "<select id=\"filter_event_id\" name=\"filter_event_id\" class=\"inputbox chzn-done\" onchange=\"submit();\" style=\"display: none;\">\n"
+ " <option value=\"0\">Select Event</option>\n"
+ " <option value=\"113\">Eventname (RB113) (02-05-2015)</option>\n"
+ " <option value=\"104\">Eventname 2 (T104) (09-05-2015)</option>\n"
+ " <option value=\"109\">Eventname 3 (M109) (15-05-2015)</option>\n"
+ " <option value=\"99\" selected=\"selected\">Eventname 4 (M99) (24-04-2015)</option>\n"
+ "</select>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}