using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?=.*protein_coding)(?=.*exon).+$";
string input = @"There is protein_coding and exon in this line
I only have exon in this line
Only protein_coding resides in this line
But exon and protein_coding both reside in this line";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}