import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?=.*protein_coding)(?=.*exon).+$";
final String string = "There is protein_coding and exon in this line\n"
+ "I only have exon in this line\n"
+ "Only protein_coding resides in this line\n"
+ "But exon and protein_coding both reside in this line";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}