const regex = new RegExp('(?m)^(?=.*protein_coding)(?=.*exon).+$', 'g')
const str = `There is protein_coding and exon in this line
I only have exon in this line
Only protein_coding resides in this line
But exon and protein_coding both reside in this line`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}