$re = '/(?m)^(?=.*protein_coding)(?=.*exon).+$/';
$str = 'There is protein_coding and exon in this line
I only have exon in this line
Only protein_coding resides in this line
But exon and protein_coding both reside in this line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);