re = /(?m)^(?=.*protein_coding)(?=.*exon).+$/
str = 'There is protein_coding and exon in this line
I only have exon in this line
Only protein_coding resides in this line
But exon and protein_coding both reside in this line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end