import Foundation
let pattern = #"(?m)^(?=.*protein_coding)(?=.*exon).+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
There is protein_coding and exon in this line
I only have exon in this line
Only protein_coding resides in this line
But exon and protein_coding both reside in this line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)