using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?!.{12})\d+(?:\.\d+)?$";
string input = @"66666666666
-66666666666
.6666666666
6.666666666
66.66666666
666.6666666
6666.666666
66666.66666
666666.6666
6666666.666
66666666.66
666666666.6
6666666666.
6666666.6666
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}