import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?!.{12})\\d+(?:\\.\\d+)?$";
final String string = "66666666666\n"
+ "-66666666666\n"
+ ".6666666666\n"
+ "6.666666666\n"
+ "66.66666666\n"
+ "666.6666666\n"
+ "6666.666666\n"
+ "66666.66666\n"
+ "666666.6666\n"
+ "6666666.666\n"
+ "66666666.66\n"
+ "666666666.6\n"
+ "6666666666.\n"
+ "6666666.6666\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}