use strict;
my $str = '66666666666
-66666666666
.6666666666
6.666666666
66.66666666
666.6666666
6666.666666
66666.66666
666666.6666
6666666.666
66666666.66
666666666.6
6666666666.
6666666.6666
';
my $regex = qr/^-?(?!.{12})\d+(?:\.\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}