const regex = /^-?(?!.{12})\d+(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?!.{12})\\d+(?:\\.\\d+)?$', 'gm')
const str = `66666666666
-66666666666
.6666666666
6.666666666
66.66666666
666.6666666
6666.666666
66666.66666
666666.6666
6666666.666
66666666.66
666666666.6
6666666666.
6666666.6666
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}