re = /^-?(?!.{12})\d+(?:\.\d+)?$/m
str = '66666666666
-66666666666
.6666666666
6.666666666
66.66666666
666.6666666
6666.666666
66666.66666
666666.6666
6666666.666
66666666.66
666666666.6
6666666666.
6666666.6666
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end