import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!https?:)\\/\\/(.+?)(?<!https?:)\\/\\/";
final String string = "fff https://stackoverflow.com<br><br>bar https://stackoverflow.com. <br>foo<br>1. //ok// - bar. //ok// - bar. //ok// - foo. //ok// - bar<br>6. //ok// -((https://stackoverflow.com)), ok (((https://stackoverflow.com bar))), fooo/ bar<br> //ok (https://stackoverflow.com bar))).//<br> foo (((https://stackoverflow.com foo)) - ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}