import re
regex = re.compile(r"(?<!https?:)\/\/(.+?)(?<!https?:)\/\/", flags=re.MULTILINE | re.IGNORECASE)
test_str = "fff https://stackoverflow.com<br><br>bar https://stackoverflow.com. <br>foo<br>1. //ok// - bar. //ok// - bar. //ok// - foo. //ok// - bar<br>6. //ok// -((https://stackoverflow.com)), ok (((https://stackoverflow.com bar))), fooo/ bar<br> //ok (https://stackoverflow.com bar))).//<br> foo (((https://stackoverflow.com foo)) - "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")