const regex = /(?<!https?:)\/\/(.+?)(?<!https?:)\/\//gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!https?:)\\\/\\\/(.+?)(?<!https?:)\\\/\\\/', 'gmi')
const str = `fff https://stackoverflow.com<br><br>bar https://stackoverflow.com. <br>foo<br>1. //ok// - bar. //ok// - bar. //ok// - foo. //ok// - bar<br>6. //ok// -((https://stackoverflow.com)), ok (((https://stackoverflow.com bar))), fooo/ bar<br> //ok (https://stackoverflow.com bar))).//<br> foo (((https://stackoverflow.com foo)) - `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}