#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\s|^|\(|\[)([0-9a-f]{7,40})(?:\s|$|\)|\]|[.,](\s|$))"
Local $sString = "7576e37a65729363370d6672ff6e69e87b68ac5f" & @CRLF & _
"x 29363370d66 x" & @CRLF & _
"x 29363370d66. x" & @CRLF & _
"x 29363370d66.x" & @CRLF & _
"x 29363370d66) x" & @CRLF & _
"x 29363370d66] x" & @CRLF & _
"x 29363370d66, x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")