import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^|\\(|\\[)([0-9a-f]{7,40})(?:\\s|$|\\)|\\]|[.,](\\s|$))";
final String string = "7576e37a65729363370d6672ff6e69e87b68ac5f\n"
+ "x 29363370d66 x\n"
+ "x 29363370d66. x\n"
+ "x 29363370d66.x\n"
+ "x 29363370d66) x\n"
+ "x 29363370d66] x\n"
+ "x 29363370d66, x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}