re = /(?:\s|^|\(|\[)([0-9a-f]{7,40})(?:\s|$|\)|\]|[.,](\s|$))/m
str = '7576e37a65729363370d6672ff6e69e87b68ac5f
x 29363370d66 x
x 29363370d66. x
x 29363370d66.x
x 29363370d66) x
x 29363370d66] x
x 29363370d66, x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end