import re
regex = re.compile(r"(?:\s|^|\(|\[)([0-9a-f]{7,40})(?:\s|$|\)|\]|[.,](\s|$))", flags=re.MULTILINE)
test_str = ("7576e37a65729363370d6672ff6e69e87b68ac5f\n"
"x 29363370d66 x\n"
"x 29363370d66. x\n"
"x 29363370d66.x\n"
"x 29363370d66) x\n"
"x 29363370d66] x\n"
"x 29363370d66, x")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")