using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|^|\(|\[)([0-9a-f]{7,40})(?:\s|$|\)|\]|[.,](\s|$))";
string input = @"7576e37a65729363370d6672ff6e69e87b68ac5f
x 29363370d66 x
x 29363370d66. x
x 29363370d66.x
x 29363370d66) x
x 29363370d66] x
x 29363370d66, x";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}