package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s|^|\(|\[)([0-9a-f]{7,40})(?:\s|$|\)|\]|[.,](\s|$))`)
var str = `7576e37a65729363370d6672ff6e69e87b68ac5f
x 29363370d66 x
x 29363370d66. x
x 29363370d66.x
x 29363370d66) x
x 29363370d66] x
x 29363370d66, x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}