using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<protocol>jsr:|npm:|node:)(\/*(@(?<scope>[^\/\s]+)\/)?(?<pkg>[^@\/\s]+)(@(?<version>[^\/\r\n\t\f\v]+))?)?(?<pathname>\/.*)?$";
string input = @"npm:/@scope/package@version/pathname
npm:package@version/pathname
npm:package
npm:package/pathname
npm:package@version
npm:package@version/pathname
npm:/package
npm:/package/pathname
npm:/package@version
npm:/package@version/pathname
npm:@scope/package
npm:@scope/package/pathname
npm:@scope/package@version
npm:@scope/package@version/pathname
npm:/@scope/package
npm:/@scope/package/pathname
npm:/@scope/package@version
npm:/@scope/package@version/pathname
npm://////package/pathname
jsr:package
jsr:package/pathname
jsr:package@version
jsr:package@version/pathname
jsr:/package
jsr:/package/pathname
jsr:/package@version
jsr:/package@version/pathname
jsr:@scope/package
jsr:@scope/package/pathname
jsr:@scope/package@version
jsr:@scope/package@version/pathname
jsr:/@scope/package
jsr:/@scope/package/pathname
jsr:/@scope/package@version
jsr:/@scope/package@version/pathname
jsr://////package/pathname
jsr:@scope/package@~2.2.0/pathname/file.ts
jsr:@scope/package@>2.1/pathname/dirname/
jsr:@scope/package@1.0.0 - 1.2.0/pathname/file.ts
jsr:package@^2 <2.2 || > 2.3
jsr:@scope/package@>=1.0.0-rc.0 <1.0.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}