import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<protocol>jsr:|npm:|node:)(\\/*(@(?<scope>[^\\/\\s]+)\\/)?(?<pkg>[^@\\/\\s]+)(@(?<version>[^\\/\\r\\n\\t\\f\\v]+))?)?(?<pathname>\\/.*)?$";
final String string = "npm:/@scope/package@version/pathname\n"
+ "npm:package@version/pathname\n"
+ "npm:package\n"
+ "npm:package/pathname\n"
+ "npm:package@version\n"
+ "npm:package@version/pathname\n"
+ "npm:/package\n"
+ "npm:/package/pathname\n"
+ "npm:/package@version\n"
+ "npm:/package@version/pathname\n"
+ "npm:@scope/package\n"
+ "npm:@scope/package/pathname\n"
+ "npm:@scope/package@version\n"
+ "npm:@scope/package@version/pathname\n"
+ "npm:/@scope/package\n"
+ "npm:/@scope/package/pathname\n"
+ "npm:/@scope/package@version\n"
+ "npm:/@scope/package@version/pathname\n"
+ "npm://////package/pathname\n"
+ "jsr:package\n"
+ "jsr:package/pathname\n"
+ "jsr:package@version\n"
+ "jsr:package@version/pathname\n"
+ "jsr:/package\n"
+ "jsr:/package/pathname\n"
+ "jsr:/package@version\n"
+ "jsr:/package@version/pathname\n"
+ "jsr:@scope/package\n"
+ "jsr:@scope/package/pathname\n"
+ "jsr:@scope/package@version\n"
+ "jsr:@scope/package@version/pathname\n"
+ "jsr:/@scope/package\n"
+ "jsr:/@scope/package/pathname\n"
+ "jsr:/@scope/package@version\n"
+ "jsr:/@scope/package@version/pathname\n"
+ "jsr://////package/pathname\n"
+ "jsr:@scope/package@~2.2.0/pathname/file.ts\n"
+ "jsr:@scope/package@>2.1/pathname/dirname/\n"
+ "jsr:@scope/package@1.0.0 - 1.2.0/pathname/file.ts\n"
+ "jsr:package@^2 <2.2 || > 2.3\n"
+ "jsr:@scope/package@>=1.0.0-rc.0 <1.0.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}