use strict;
my $str = 'npm:/@scope/package@version/pathname
npm:package@version/pathname
npm:package
npm:package/pathname
npm:package@version
npm:package@version/pathname
npm:/package
npm:/package/pathname
npm:/package@version
npm:/package@version/pathname
npm:@scope/package
npm:@scope/package/pathname
npm:@scope/package@version
npm:@scope/package@version/pathname
npm:/@scope/package
npm:/@scope/package/pathname
npm:/@scope/package@version
npm:/@scope/package@version/pathname
npm://////package/pathname
jsr:package
jsr:package/pathname
jsr:package@version
jsr:package@version/pathname
jsr:/package
jsr:/package/pathname
jsr:/package@version
jsr:/package@version/pathname
jsr:@scope/package
jsr:@scope/package/pathname
jsr:@scope/package@version
jsr:@scope/package@version/pathname
jsr:/@scope/package
jsr:/@scope/package/pathname
jsr:/@scope/package@version
jsr:/@scope/package@version/pathname
jsr://////package/pathname
jsr:@scope/package@~2.2.0/pathname/file.ts
jsr:@scope/package@>2.1/pathname/dirname/
jsr:@scope/package@1.0.0 - 1.2.0/pathname/file.ts
jsr:package@^2 <2.2 || > 2.3
jsr:@scope/package@>=1.0.0-rc.0 <1.0.1
';
my $regex = qr/^(?<protocol>jsr:|npm:|node:)(\/*(@(?<scope>[^\/\s]+)\/)?(?<pkg>[^@\/\s]+)(@(?<version>[^\/\r\n\t\f\v]+))?)?(?<pathname>\/.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}