const regex = /^(?<protocol>jsr:|npm:|node:)(\/*(@(?<scope>[^\/\s]+)\/)?(?<pkg>[^@\/\s]+)(@(?<version>[^\/\r\n\t\f\v]+))?)?(?<pathname>\/.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<protocol>jsr:|npm:|node:)(\\\/*(@(?<scope>[^\\\/\\s]+)\\\/)?(?<pkg>[^@\\\/\\s]+)(@(?<version>[^\\\/\\r\\n\\t\\f\\v]+))?)?(?<pathname>\\\/.*)?$', 'gm')
const str = `npm:/@scope/package@version/pathname
npm:package@version/pathname
npm:package
npm:package/pathname
npm:package@version
npm:package@version/pathname
npm:/package
npm:/package/pathname
npm:/package@version
npm:/package@version/pathname
npm:@scope/package
npm:@scope/package/pathname
npm:@scope/package@version
npm:@scope/package@version/pathname
npm:/@scope/package
npm:/@scope/package/pathname
npm:/@scope/package@version
npm:/@scope/package@version/pathname
npm://////package/pathname
jsr:package
jsr:package/pathname
jsr:package@version
jsr:package@version/pathname
jsr:/package
jsr:/package/pathname
jsr:/package@version
jsr:/package@version/pathname
jsr:@scope/package
jsr:@scope/package/pathname
jsr:@scope/package@version
jsr:@scope/package@version/pathname
jsr:/@scope/package
jsr:/@scope/package/pathname
jsr:/@scope/package@version
jsr:/@scope/package@version/pathname
jsr://////package/pathname
jsr:@scope/package@~2.2.0/pathname/file.ts
jsr:@scope/package@>2.1/pathname/dirname/
jsr:@scope/package@1.0.0 - 1.2.0/pathname/file.ts
jsr:package@^2 <2.2 || > 2.3
jsr:@scope/package@>=1.0.0-rc.0 <1.0.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}