// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<protocol>jsr:|npm:|node:)(\/*(@(?<scope>[^\/\s]+)\/)?(?<pkg>[^@\/\s]+)(@(?<version>[^\/\r\n\t\f\v]+))?)?(?<pathname>\/.*)?$").unwrap();
let string = "npm:/@scope/package@version/pathname
npm:package@version/pathname
npm:package
npm:package/pathname
npm:package@version
npm:package@version/pathname
npm:/package
npm:/package/pathname
npm:/package@version
npm:/package@version/pathname
npm:@scope/package
npm:@scope/package/pathname
npm:@scope/package@version
npm:@scope/package@version/pathname
npm:/@scope/package
npm:/@scope/package/pathname
npm:/@scope/package@version
npm:/@scope/package@version/pathname
npm://////package/pathname
jsr:package
jsr:package/pathname
jsr:package@version
jsr:package@version/pathname
jsr:/package
jsr:/package/pathname
jsr:/package@version
jsr:/package@version/pathname
jsr:@scope/package
jsr:@scope/package/pathname
jsr:@scope/package@version
jsr:@scope/package@version/pathname
jsr:/@scope/package
jsr:/@scope/package/pathname
jsr:/@scope/package@version
jsr:/@scope/package@version/pathname
jsr://////package/pathname
jsr:@scope/package@~2.2.0/pathname/file.ts
jsr:@scope/package@>2.1/pathname/dirname/
jsr:@scope/package@1.0.0 - 1.2.0/pathname/file.ts
jsr:package@^2 <2.2 || > 2.3
jsr:@scope/package@>=1.0.0-rc.0 <1.0.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}