package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(<\/?a\b(?:\s+[a-z]+="[^"]*")*[^>]*>)`)
var str = ` <a>foo</a> <a href="foo">foo</a> <a href="<foo>">foo</a> <a href="" title="">foo</a> <aa></aa> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}