import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/?a\\b(?:\\s+[a-z]+=\"[^\"]*\")*[^>]*>)";
final String string = " <a>foo</a> <a href=\"foo\">foo</a> <a href=\"<foo>\">foo</a> <a href=\"\" title=\"\">foo</a> <aa></aa> ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}