re = /(<\/?a\b(?:\s+[a-z]+="[^"]*")*[^>]*>)/i
str = ' <a>foo</a> <a href="foo">foo</a> <a href="<foo>">foo</a> <a href="" title="">foo</a> <aa></aa> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end