import re
regex = re.compile(r"(<\/?a\b(?:\s+[a-z]+=\"[^\"]*\")*[^>]*>)", flags=re.IGNORECASE | re.DOTALL | re.UNICODE)
test_str = " <a>foo</a> <a href=\"foo\">foo</a> <a href=\"<foo>\">foo</a> <a href=\"\" title=\"\">foo</a> <aa></aa> "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")