#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1-9]{2}|50)-[0-9]{3,4}$"
Local $sString = "11-184" & @CRLF & _
"11-0132" & @CRLF & _
"12-729" & @CRLF & _
"13-276" & @CRLF & _
"13-35" & @CRLF & _
"13-3573" & @CRLF & _
"14-453" & @CRLF & _
"15-743" & @CRLF & _
"16-2576" & @CRLF & _
"16-251" & @CRLF & _
"17-34567" & @CRLF & _
"17-345" & @CRLF & _
"18-730" & @CRLF & _
"19-137" & @CRLF & _
"19-3a61" & @CRLF & _
"50-947" & @CRLF & _
"50-2693"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")