import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]{2}|50)-[0-9]{3,4}$";
final String string = "11-184\n"
+ "11-0132\n"
+ "12-729\n"
+ "13-276\n"
+ "13-35\n"
+ "13-3573\n"
+ "14-453\n"
+ "15-743\n"
+ "16-2576\n"
+ "16-251\n"
+ "17-34567\n"
+ "17-345\n"
+ "18-730\n"
+ "19-137\n"
+ "19-3a61\n"
+ "50-947\n"
+ "50-2693";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}