// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([1-9]{2}|50)-[0-9]{3,4}$").unwrap();
let string = "11-184
11-0132
12-729
13-276
13-35
13-3573
14-453
15-743
16-2576
16-251
17-34567
17-345
18-730
19-137
19-3a61
50-947
50-2693";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}