# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([1-9]{2}|50)-[0-9]{3,4}$"
test_str = ("11-184\n"
"11-0132\n"
"12-729\n"
"13-276\n"
"13-35\n"
"13-3573\n"
"14-453\n"
"15-743\n"
"16-2576\n"
"16-251\n"
"17-34567\n"
"17-345\n"
"18-730\n"
"19-137\n"
"19-3a61\n"
"50-947\n"
"50-2693")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.