$re = '/([1-9]{2}|50)-[0-9]{3,4}$/m';
$str = '11-184
11-0132
12-729
13-276
13-35
13-3573
14-453
15-743
16-2576
16-251
17-34567
17-345
18-730
19-137
19-3a61
50-947
50-2693';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);