package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^DK[0-6]{4}$`)
var str = `The regex DK[0-9]{4} specifies that the input must start with "DK" and then be followed by 4 digits from 0 to 6
The following example values are valid:
DK0001
DK1323
DK6666
The following example values are invalid
DK0007
DK0009
DK 3434
DK232
DK1
DK01
DK001
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}