use strict;
my $str = 'The regex DK[0-9]{4} specifies that the input must start with "DK" and then be followed by 4 digits from 0 to 6
The following example values are valid:
DK0001
DK1323
DK6666
The following example values are invalid
DK0007
DK0009
DK 3434
DK232
DK1
DK01
DK001
';
my $regex = qr/^DK[0-6]{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}