import re
regex = re.compile(r"^DK[0-6]{4}$", flags=re.MULTILINE)
test_str = ("The regex DK[0-9]{4} specifies that the input must start with \"DK\" and then be followed by 4 digits from 0 to 6\n\n"
"The following example values are valid:\n"
"DK0001\n"
"DK1323\n"
"DK6666\n\n"
"The following example values are invalid\n"
"DK0007\n"
"DK0009\n"
"DK 3434\n"
"DK232\n"
"DK1\n"
"DK01\n"
"DK001\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")