import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^DK[0-6]{4}$";
final String string = "The regex DK[0-9]{4} specifies that the input must start with \"DK\" and then be followed by 4 digits from 0 to 6\n\n"
+ "The following example values are valid:\n"
+ "DK0001\n"
+ "DK1323\n"
+ "DK6666\n\n"
+ "The following example values are invalid\n"
+ "DK0007\n"
+ "DK0009\n"
+ "DK 3434\n"
+ "DK232\n"
+ "DK1\n"
+ "DK01\n"
+ "DK001\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}