import Foundation
let pattern = #"^DK[0-6]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The regex DK[0-9]{4} specifies that the input must start with "DK" and then be followed by 4 digits from 0 to 6
The following example values are valid:
DK0001
DK1323
DK6666
The following example values are invalid
DK0007
DK0009
DK 3434
DK232
DK1
DK01
DK001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)