const regex = /^DK[0-6]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^DK[0-6]{4}$', 'gm')
const str = `The regex DK[0-9]{4} specifies that the input must start with "DK" and then be followed by 4 digits from 0 to 6
The following example values are valid:
DK0001
DK1323
DK6666
The following example values are invalid
DK0007
DK0009
DK 3434
DK232
DK1
DK01
DK001
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}