package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([1-9]\d{5})(18|19|([23]\d))\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\d{3}[0-9Xx]))|(^[1-9]\d{5}\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\d{2})`)
var str = ` jkjk@abchi.comsdfds13544448888 16633331111
410581198807229059`
var substitution = "$2*********$8"
fmt.Println(re.ReplaceAllString(str, substitution))
}