const regex = new RegExp('(([1-9]\\d{5})(18|19|([23]\\d))\\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\\d{3}[0-9Xx]))|(^[1-9]\\d{5}\\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\\d{2})', 'gm')
const str = ` jkjk@abchi.comsdfds13544448888 16633331111
410581198807229059`;
const subst = `$2*********$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);