// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([1-9]\d{5})(18|19|([23]\d))\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\d{3}[0-9Xx]))|(^[1-9]\d{5}\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\d{2})").unwrap();
let string = " jkjk@abchi.comsdfds13544448888 16633331111
410581198807229059";
let substitution = "$2*********$8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}