$re = '/(([1-9]\d{5})(18|19|([23]\d))\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\d{3}[0-9Xx]))|(^[1-9]\d{5}\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\d{2})/m';
$str = ' jkjk@abchi.comsdfds13544448888 16633331111
410581198807229059';
$subst = "$2*********$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;