import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([1-9]\\d{5})(18|19|([23]\\d))\\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\\d{3}[0-9Xx]))|(^[1-9]\\d{5}\\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\\d{2})";
final String string = " jkjk@abchi.comsdfds13544448888 16633331111\n\n"
+ "410581198807229059";
final String subst = "$2*********$8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}