# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?_.*?_.*?)_/\1 /gm;t' <<< "john_doe_13456_20_m_v5
john_doe_13456_20_m_n7_abc
john_doe_13456_20_m_t44
john_doe_13456_20_m_m13_bca_1
john_doe_13456_20_m_v5"