$re = '/^(.*?_.*?_.*?)_/m';
$str = 'john_doe_13456_20_m_v5
john_doe_13456_20_m_n7_abc
john_doe_13456_20_m_t44
john_doe_13456_20_m_m13_bca_1
john_doe_13456_20_m_v5';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;